You are viewing the MafiaScum.net Wiki. To play the game, visit the forum.

Don't Panic

From MafiaWiki
Jump to: navigation, search
This page has been protected against IP/brand new user edits. Please log in if you wish to edit this page, or use the talk page to discuss removing protection.

This page is for when you are having problems getting into the Forums in order to document that you're... having a problem with the Forums. Use the discussion page on this page to report problems; only update this page if you know for certain what is going on. A site administrator can then post follow-up comments, or edit the main page to provide a status update. See also the main site's Don't Panic page for those times when all forum and wiki access is disabled.

Other places to look in the event of downtime:

Status

No issues detected.

Older Status

May 14-17, 2016

Cross-posting from facebook - the server is currently unreachable, I have filed a ticket with our hosting provider.

Nothing to report on my end - I got a response that they were looking into the issue last night, but nothing since.

Current operational status is mostly online: things such as viewthread.php, viewforum.php, and search.php are still missing. That leaves Sitechat and the Wiki as the only fully functional resources at the moment. Please feel free to update this further as more information becomes available. Tn5421 (talk) 07:51, 17 May 2016 (EDT)

Update: As of now the site is fully functional, courtesy of Kison. Please give him a big round of applause. Tn5421 (talk)

December 6, 2013

We are in the midst of a server move to newer hardware. While this will overall be an improvement for the site, right now it is causing some occasional slowdowns (the database is in one place, the forum software another) and the email server is glitching. If you have problems registering, post in the Help! forum. -- Mr. Flay 14:14, 6 December 2013 (UTC)

October 27, 2011

A scriptkiddie is playing games with the search function, trying to overload the server. Needless to say it's not working, but to reduce strain we've made a few changes to how search works. Shouldn't impact normal users much. -- Mr. Flay 14:16, 27 October 2011 (EDT)

June 8, 2011

Server burp/misconfiguration led to some intermittent and unpredictable downtimes this evening. A fix was eventually found, and the server maintainer is working on a longer-term solution to this problem, to keep it from cropping up again. -- Mr. Flay 11:35, 11 June 2011 (EDT)

June 6, 2011

We are conducting a forum upgrade to 3.0.8 - it may take an hour or two for the site to come back up (instead of the original 30-40 minutes), but there are no anticipated problems beyond time frame. Have a Coke. -- Mr. Flay 20:58, 6 June 2011 (EDT)

Aaaaand we're back. -- Mr. Flay 21:30, 6 June 2011 (EDT)

June 15, 2010

We have successfully completed both a server move and a forum upgrade. The site may continue to be slow for another day or two while the archive finishes converting all 1.7 million posts... --Mr. Flay

January 10, 2008

The site has been down a for a few hours the past couple days, apparently due to an upgrade to the Apache server, which caused something on our end to be not-compatible. That's been fixed. However, the site has been quite slow since the "upgrade", and I just got a php Critical Error. Hopefully we'll have this sorted soon. -- mith

April 20, 2007

We were recently updated to a new server. During the move, our databases were left behind and then deleted. My backup from the day of the move (which was lucky, we didn't get any warning for the move) was corrupt (which was unlucky, obviously). I lost the SQL connection in the middle. Its uncompressed size was slightly larger than the compressed size of the other backups, so I didn't notice the corruption until I tried to recover. Fortunately I had a backup from the 12th. So we lost about 4 days of data. The wiki was not so lucky. I haven't been doing regular backups of the wiki, it just wasn't on my radar. I did have one from before the last software update. So we lost about 6 weeks of wiki data. The archive and invitational are unharmed. Sorry for the inconvenience. If we were given notice OR if Bluehost hadn't been incompetent in the move, we wouldn't have had any issues. I'd like to encourage those of you who love the site to donate. (Ignore mith's artificial limit of $10 and give what you feel it's worth to you while factoring in your financial situation. Don't prevent yourself from eating, of course.) -Jeep 02:03, 20 April 2007 (MDT)

November 29, 2006

They are going to try moving us to another box on the same plan. They also have a "level 3" looking into the problem (I think I managed to at least convince Jaime, the guy on tonight, that some of the problems we're having can't be caused by our code). If this doesn't work, the next try will likely be to move to the high CPU server for a bit to see if that helps.

Fingers crossed… -mith

November 27, 2006

A quick update:

Saturday, I spent about two hours in live chat with a bluehost guy. He was pretty much completely unhelpful. He did give us a couple things to try, but jeep and I think that it is more likely that there is a problem with the box we're on rather than anything we're doing. There are some things going slowly that just shouldn't be going slowly, however many users we have or however big our database is.

Anyway, I am going to be looking at other hosting. In the meantime, I've requested a move to bluehost's higher CPU plan (actually, I've opened a ticket asking for a few details about that, but moving boxes doesn't take much time). If we're right and it's just the box we're on, that should get us back up and running just fine. If not, hopefully it will at least be a temporary fix and I can continue looking for a good host.

It's possible that we have simply outgrown what bluehost can offer. If that's the case, we may be looking at a significant jump in price, and so I may be requesting some small donations. I want to make it clear before I even ask for them (and I may never ask for them) that it would be entirely voluntary and anonymous, and donating wouldn't buy you any special status or anything, just my gratitude.

Thank you for your patience, and I'll hopefully see you all on the forums soon.

-mith

November 20, 2006

Deactivated again. I've disabled the forum while we look through the logs again. Might have to switch boxes. More later. -mith

November 12, 2006

Forum is back up and running, with all search functions disabled at present. Occasional "CPU quota" errors are showing up transiently; wait a few minutes and they should go away. Also read this post by JEEP if you have any troubles at all!

November 7, 2006

Alright, so I am thinking that the view all is the bulk of our issue. It is being used FAR more frequently than I imagined. I thought that it would be used very occasionally. Instead it looks like many people are using it almost exclusively. So I'm going to remove that feature. The same function exists in the printer friendly view, but I will also ask that it only be used rarely (I'm going to put a nag screen before I execute the query if there are more than 35 posts and show all is picked.) If you have been using the feature, you are not to blame for this issue and I'm not even certain this is the full problem.

I will disable that and put back in some of the mods that were lost at the time of the move. I'll be ready to start things up in the next day or so, but we'll want to coordinate turning it on. mith or I will need to contact the host, and beg them to send us an e-mail before they shut us off again. We'll need to be available so that we can disable the board immediately if there is a problem. I probably won't update the status again until I'm ready to re-enable the board.


The repair returned with all OK, but it was formatted weirdly. I re-ran it and it came back with all OK in the correct format. So that part is done. I am going to restore the database to another instance and play around with things there. I'm looking through the logs and it doesn't look like our usage has changed recently (if you ignore the down time). I'm continuing to look through the reports but the queries are WIDELY varied. The search functions are the only ones that appear more frequently than the others. Perhaps it's used more?

Of course, that makes me remember that the "show all" feature uses the search function. Does anyone use that on a regular basis? It's supposed to be used for the rare time when you need to see everything and shouldn't be used as the standard way of viewing topics! If you do use show all normally, PLEASE send me an e-mail. I need more information unless I just start shotgunning the problem. Also, spread the word that I'm looking for more information among scummers you chat with.

-JEEP

November 6, 2006

UPDATE: I am uploading a backup of our data into a temporary database. I am going to do some testing on it. There were a LOT of searches in the slow queries, but since they shut us down even after I disabled it, I need to look at the other slow queries in more detail.

In the meantime, I'm running a repair function on the database to see if it finds anything. I'll get it back up ASAP.


See also